API Maintenance Notice

Incident Report for eSIM Access

Resolved

【 API Maintenance Notice 】: Scheduled Maintenance Completed – Upstream Supplier Upgrade (Jul 1, 2026)

Dear Partner,
This is to confirm that the scheduled maintenance by our upstream supplier ( infrastructure upgrade ) has been completed.

Maintenance window: July 1, 2026, 18:00–22:00 CEST
Status: Completed — services have returned to normal

Affected regions (Morocco, North America (3 areas), Saudi Arabia, United States) are now fully operational. Our team continued to monitor service availability throughout the window and has confirmed stability post-maintenance.

If you or your customers experienced any disruption during this period, please don't hesitate to reach out — our support team is available 24/7 at help@esimaccess.com to assist with replacement orders if needed.

Thank you for your patience and understanding.

Your satisfaction drives us. 7/24. Worldwide.
eSIM Access Team
Posted Jul 01, 2026 - 20:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 01, 2026 - 16:07 UTC

Monitoring

【 API Maintenance Notice 】: Scheduled Maintenance Notice – Upstream Supplier Upgrade (Jul 1, 2026)

Dear Partner,
We would like to inform you of upcoming scheduled maintenance by our upstream supplier that may briefly affect eSIM data sessions in the following regions:

Morocco
North America (3 areas)
Saudi Arabia
United States

Maintenance window: July 1, 2026, 18:00–22:00 CEST
Impact: brief interruptions of up to one minute.

Please note:

1. We will closely monitor service availability throughout the maintenance window.
2. We offer backup resources available to process replacement orders in case of any disruption for your customers.
3. Our support team is available 24/7 — please reach out at help@esimaccess.com for replacement orders if needed.

We appreciate your understanding.

Your satisfaction drives us. 7/24. Worldwide.
eSIM Access Team
Posted Jul 01, 2026 - 15:57 UTC
This incident affected: API.